Представим себе такой процесс в компании. Каждое утро сотрудник приходит в офис, берёт кучу распечатанных из 1с документов и уходит на целый день в «поля». По окончанию работы в офисе появляются подписанные документы, по которым надо оператору проставить выполнение документа в базе учёта 1с. Чтобы помочь в автоматизации данного действия можно предложить использовать следующее:

  • штрих-кодирование распечатанных документов, по которым предполагается выполнение какого-го либо действия в будущем.
  • необходимо у пользователя 1с искать в базе документ по штрих-коду.

Когда документов много и операции по отметке выполнения однотипные  поэлементный поиск будет тормозить работу оператора. В таком случае можно предложить использовать потоковое сканирование. Сотрудник подписанные документы кладёт в сканер с механизмом автоподачи. Сканер помещает отсканированные изображения в сетевую папку. Пользователь 1с по окончанию работы со сканером запускает распознавание штрих-кодов из папки с отсканированными озображениями с последующим выводом списка документов на экран.

Чтобы распознать штрих-коды с изображений можно воспользоваться компонентой документооборота. Ниже код по распознаванию с использование данной компоненты.

&НаСервере
Функция РаспознатьШтрихКодОдногоФайла(ИмяФайлаКартинки, ПрерватьПроцессСканирования)
ШагСканирования = 10;
Если КомпонентаРаспознаванияШтрихкодов = Неопределено Тогда
ПодключитьКомпоненту();
КонецЕсли;
СтрокаВозврата = КомпонентаРаспознаванияШтрихкодов.РаспознатьШтрихкоды(ИмяФайлаКартинки, ШагСканирования);
Если Найти(СтрокаВозврата, "Error.") = 1 Тогда // есть ошибка
СтрокаОшибкиКомпоненты = Сред(СтрокаВозврата, СтрДлина("Error.") + 1);
ТекстОшибки = "Ошибка распознавания штрихкода:" + СтрокаОшибкиКомпоненты;
Сообщить(ТекстОшибки);
Возврат Неопределено;
КонецЕсли;

Возврат СтрокаВозврата;
КонецФункции

Далее по полученным штрих-кодам необходимо найти владельцев и работать уже с ссылочными данными. По ссылочным данным уже можно понять какой алгоритм необходимо запускать для того или иного объекта. По результатам внедрения такого подхода могу сказать что он существенно сокращает время обрабатываемой информации, поступающей от сотрудников.
scan