Столкнулся с вопросом как сохранить файл на стороне клиента, который был создан на стороне сервера. Подход такой: вызываем серверную процедуру, которая получает имя временного файла, в него записывает необходимые данные. Затем, имея в наличии имя файла на диске сервера, помещаем его во временное хранилище.  Пользователю предлагается скачать файл с помощью метода ПолучитьФайл().

&НаСервере
Функция СформироватьФайл()
    ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
    //Тут создаем наш файл и записываем его в ИмяВременногоФайла
    //...................
    //...................

    //Возвращаем на клиент адрес во временном хранилище
    Возврат ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ИмяВременногоФайла), УникальныйИдентификатор);
КонецФункции

&НаКлиенте
Процедура СоздатьФайл(Команда)
    Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
        Попытка
            УстановитьРасширениеРаботыСФайлами();
        Исключение
            Сообщить(ОписаниеОшибки());
            Возврат;
        КонецПопытки;
    КонецЕсли;

    Если ПодключитьРасширениеРаботыСФайлами() Тогда
        СсылкаСкачивания = СформироватьФайл();
        ПолучитьФайл(СсылкаСкачивания, "МойФайл");
    КонецЕсли;
КонецПроцедуры